KO 000001 1 EL NIF ENVIADO POR LA TASADORA NO COINCIDE CON EL QUE EXISTE EN PARTNER DATA PARA ESE CLIENTE (SOLO MANUALES)
IDENTIFICACIÓN DEL PROBLEMA:
Se necesita saber cuáles son el Número y el Tipo de Identidad en nuestros sistemas (GLIT) y los enviados.
- Consultar los valores en la Pantalla Solicitudes de la aplicación:
- Consultar los valores en NifCliente y TipoNifCliente en el último Informe XML en la Documentación, la información enviada del cliente:
<Request_Cliente> <NombreCliente> ALINA RAMONITA</NombreCliente> <Ape1Cliente>MANEA</Ape1Cliente> <Ape2Cliente/> <NifCliente>X8513699L</NifCliente> <SecNifCliente>001</SecNifCliente> <TipoNifCliente>3</TipoNifCliente> </Request_Cliente>
El mapeo actual del tipo de documento es:
Documento |
GLIT |
DB |
NIF |
1 |
1 |
NIF-IVA |
2 |
1 |
Pasaporte |
3 |
2 |
Documento Oficial |
5 |
3 |
NIE |
7 |
3 |
CIF |
8 |
5 |
A nivel de código, está en GeneraXMLEnvioClientes.valoresDB.getTipoNifCliente
Además, se puede consultar el valor del NIF en las Notas del Agente en la documentación:
DIAGNÓSTICO:
El KO indica que no se corresponden el valor del NIF (incluido el tipo de documento) con los presentes en los sistemas de DB.
CAUSA:
Comprobar si los valores del NIF son iguales en GLIT, en el Informe XML y la nota del agente.
Comprobar si el tipo de documento es coherente con respecto al número de identidad.
Usar las Tablas DNI para mayor información.
SOLUCIÓN:
Si el tipo de documento no cumple con el formato que tiene el número de Identidad, pedir al usuario que compruebe el valor del tipo.
Si no parece haber error, preguntar si se ha cotejado con lo que tiene el cliente.